共识错误导致以太坊链分裂

关键要点

  • 以太坊软件客户端 Geth 的旧版本中的一个错误导致以太坊主网上的链分裂。
  • 据报道,Flexpool、BTC.com 和 Binance 的矿池一直在使用旧版本进行挖矿。
  • 加密社区的成员建议用户在问题解决之前避免在网络上进行交易。

分享此文章

由于旧版本的 Geth 中的错误,以太坊区块链已经分裂。

Bug 导致以太坊分叉

影响旧版以太坊网络客户端 Geth 的错误导致节点与主网络分离。 该漏洞有可能导致双花攻击和交易用户损失的危险。

虽然该错误已在 Geth 版本 v1.10.8. 中修复,但据认为许多节点正在运行旧的、未打补丁的版本。

Tim Beiko,以太坊“AllCoreDevs”的一部分, 建议 Flexpool、BTC.com 和 币安的 pools 一直在旧版本的 Geth 上挖矿。

共识错误还会影响以太坊以外的链,包括 Polygon、Binance Smart Chain、xDAI 等。 有谣言在 Twitter 上流传,该漏洞可能已经在以太坊和 币安智能链.

多边形 发推文 其网络上的大多数验证器已经更新到最新的 Geth/Bor 版本。

幸运的是,大多数以太坊矿工都在运行更新版本的 Geth 客户端,这意味着不存在硬分叉的风险。 关于运行旧版本 Geth 的非挖矿节点,它们实际上被禁止访问主网络。

作为预防措施,加密社区的成员建议用户不要在以太坊和其他链上进行重大交易,直到问题得到解决并且大多数节点更新到最新版本的 Geth 软件为止。 “在确认之前不要做 txs,除非你确定你正在提交最新的 geth,”DeFi 开发人员 Andre Cronje 写了. “去外面散散步,我们都需要。”

披露:在撰写本文时,此功能的作者拥有 ETH。 Andre Cronje 是 Crypto Briefing 的股东。

分享此文章




阅读更多

关于 crypto

Check Also

尽管两周暴跌,以太坊多头仍可能从 ETH 期权中获利 1.3 亿美元

乙醚 (以太坊) 在 2021 …

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注